phpstudy 2016(PHP环境一键安装包) 支持php7 最新更新|软件分类|软件专题|手机版|论坛转贴|软件发布

您当前所在位置:首页网络软件服务器区 → phpstudy 2016(PHP环境一键安装包) 支持php7

phpstudy 2016(PHP环境一键安装包) 支持php7

phpstudy2016下载|

phpstudy 2016(PHP环境一键安装包)

版本

  • 软件大小:52M
  • 软件语言:中文
  • 软件类型:国产软件/服务器区
  • 软件授权:免费软件
  • 更新时间:2019-09-26 10:19
  • 软件等级:4星
  • 应用平台:WinXP, Win7, Win8, Win10
  • 软件官网:

软件介绍人气软件精品推荐相关文章网友评论下载地址

小编为您推荐: phpstudy php

phpstudy 2016.11.03是最新版本的网站php环境搭建程序,集成了最新的Apache、Nginx、LightTPD、PHP、MySQL等等,包括PHP调试环境、开发工具、开发手册等,内附详细的有需要的安装使用教程,用户欢迎来IT猫扑下载~

phpstudy 2016 php7简介

目标:让天下没有难配的php环境。

phpStudy Linux版&Win版同步上线 支持Apache/Nginx/Tengine/Lighttpd/IIS7/8/6

一次性安装,无须配置即可使用,是非常方便、好用的PHP调试环境。该程序绿色小巧简易迷你仅有32M,有专门的控制面板。总之学习PHP只需一个包。

对学习PHP的新手来说,WINDOWS下环境配置是一件很困难的事;对老手来说也是一件烦琐的事。因此无论你是新手还是老手,该程序包都是一个不错的选择。

全面适合 Win2000/XP/2003/win7/win8/win2008 操作系统 ,支持Apache、IIS、Nginx和LightTPD。

新特征:完美支持win10,支持自定义php版本

phpstudy 2016.crazyarcadefun.com

曾道人一键切换 apache+php

phpstudy 2016.crazyarcadefun.com

php扩展管理超级方便

phpstudy 2016.crazyarcadefun.com

nginx+php

phpstudy 2016.crazyarcadefun.com

曾道人IIS7/8/6+php

phpstudy 2016.crazyarcadefun.com

曾道人mysql备份还原导入导出

phpstudy 2016.crazyarcadefun.com

站点域名设置

phpstudy 2016.crazyarcadefun.com

端口检测

phpstudy 2016.crazyarcadefun.com

曾道人JspStudy(jsp环境集成包) jdk+tomcat6+tomcat8+mysql+apache

曾道人JspStudy下载:http://www.phpstudy.net/phpstudy/JspStudy.zip

phpstudy 2016.crazyarcadefun.com

phpstudy 2016简介

曾道人JspStudy集成JDK+tomcat+Apache+mysql,JSP环境配置一键启动。无需修改任何配置即可迅速搭建支持JSP的服务器运行环境。

曾道人纯绿色解压即可,支持系统服务和非服务两种启动方式,自由切换。控制面板更加有效直观地进行控制程序的启停。

曾道人JspStudy将复杂的JSP环境配置简单化。

phpStudy 2016同亿品元素先前介绍的USBWebserver、UwAmp一样,是一款网站php环境搭建程序,不过phpStudy 2016相对另外两款程序,功能更加强大。phpStudy 2016支持最新的PHP 7.0,该程序包集成了最新的Apache+Nginx+LightTPD+PHP+MySQL+phpMyAdmin+Zend Optimizer+Zend Loader,一次性安装,无须配置即可使用,是非常方便、好用的PHP调试环境。该程序绿色小巧简易迷你仅有32M,有专门的控制面板。总之学习PHP、搭建网站php环境只需一个包,简单易用。

phpstudy2016使用教程

对学习PHP的新手来说,WINDOWS下环境配置是一件很困难的事;对老手来说也是一件烦琐的事。因此无论你是新手还是老手,phpStudy 2016程序包都是一个不错的选择。

1、phpStudy 2016全面适合 Win2000/XP/2003/win7/win8/win2008 操作系统 ,支持Apache、IIS、Nginx和LightTPD。

曾道人2、phpStudy 2016程序包集成以下软件,括号内为phpstudy下对应的目录。

曾道人php 7.0.1   (php70n)

曾道人php 5.5.30-nts   (php55n)

曾道人php 5.4.33-nts   (php54n)

php 5.3.29   (php53)

php 5.3.29-nts   (php53n)

曾道人php 5.2.17   (php52)

曾道人Apache 2.4.18   (Apache)

曾道人Nginx 1.9.9   (nginx)

曾道人MySQL 5.7.10   (MySQL)

MySQL-Front 5.3   (SQL-Front)

phpMyAdmin 3.5.8.2   (phpMyAdmin)

ZendOptimizer 3.3.3   (php5.2有)

曾道人Zend Loader 5.5.0   (php5.3有)

Zend Loader 6.0.0   (php5.4有)

wincache 1.3.5   (fastcgi有)

php_opcache 7.0.3  (ZendOpcache扩展)

xdebug 2.2.5

xcache  3.1.0

eAccelerator 1.0&0.9.6

php_sqlsrv   (MSSQL扩展)

php_pdo_sqlsrv   (PDO-MSSQL扩展)

SendMail 3.2   (sendmail)

曾道人26种组合一键切换 apache+php

曾道人3、MySQL数据库默认用户名:root,密码root,安装后请重新设置密码。

曾道人4、phpStudy纯绿色,支持22种组合一键切换,支持系统服务和非服务两种启动方式,自由切换。改变安装路径或拷贝到别的电脑上也可正常运行;即便是运行完再更改路径也能运行,真正做到无须配置。重写控制面板更加有效直观地进行控制程序的启停。

5、自带FTP服务器,支持多用户,无需再安装FTP服务器。自带网站挂马监视器,随时记录文件的修改情况,让挂马文件无处可逃。

6、phpStudy完美支持II7,IIS8和IIS6。应网友的要求制作Nginx版和Lighttpd版。Nginx版为phpfind,Lighttpd版为phpLight。

推荐:学习JSP用JspStudy。

『特别注意』

曾道人1. 为了减少出错安装路径不得有汉字,如有防火墙开启,会提示是否信任httpd、mysqld运行,请选择全部允许。

曾道人2. 此为apache+php方案,需要Nginx+php方案的请到www.phpStudy.net下载phpfind,Lighttpd+PHP方案下载phpLight。

3. 重装系统后或相关服务丢失时,只需要点一下『运行模式-应用』即可。

4. 可通过菜单『卸载相关服务』进行卸载相关服务。

曾道人5. 在『启动』、『停止』、『重启』三个启停按钮上右键可以有选择地进行启停,左键将控制全部的启停。

6. 菜单『phpStudy 设置』可以进行php,apche,mysql的相关设置。菜单『站点域名设置』可以进行站点及域名的添加。

曾道人7. 本程序分为安装版和非安装版,无论是安装还是免安装,最后的效果完全一致。

8. 端口问题无法启动时,请使用菜单『强制启动端口』进行端口检测,尝试启动。

系统服务和非服务启动的区别:

曾道人系统服务启动:开机就会启动,适合经常使用或做服务器,无需手工启动,服务会随开机而启动,好处程序运行稳定。

曾道人非服务启动:需要手动启动一下,适合偶尔经常使用一下。在不使用的情况不会启动相关进程,从而节省电脑的资源。

『特别声明』该程序没有任何商业目的,之所以取名为phpStudy,仅作学习之用,不得用于商业用途;该程序所包括的软件版权归原作者所有。对于使用此程序给您造成的任何损失,本人概不负责!

曾道人MySQL数据库默认用户名:root,密码root (为什么很多人看不到呢!!!)

曾道人phpStudy提示没安装Zend或Zend Optimizer not Installed

phpStudy是自带Zend Optimizer和Zend Guard Loader,

但是php5.3及以后的版本Zend Optimizer改名Zend Guard Loader。

曾道人php5.3及以后的版本Zend Optimizer改名Zend Guard Loader。

曾道人是zend官方改名不是我改的哟。

也就是说需要Zend Optimizer的程序将不能安装到php5.3以后的版本。

所以下载phpStudy之后切换到php5.2即可解决问题。

需要Zend Guard Loader的切换到php5.3和php5.4,但是必须是以fastcgi模式运行

曾道人参照:http://www.phpstudy.net/a.php/181.html

IIS7/8快速安装PHP及phpStudy注意事项

phpStudy支持win7/8和win2008/2012的IIS7/8。win8最好以管理员身份运行。已经测试过N次了。

曾道人但是在安装前要注意激活FastCGI 模块

曾道人默认安装的 IIS 中 FastCGI 模块被关闭。要激活其的步骤在不同版本的 Windows 下不同。

要在 Windows Vista SP1 和 Windows 7 中激活 FastCGI 支持:

在 Windows 开始菜单中选择“运行...”(或在搜索框内),输入“optionalfeatures.exe”并按“确定”(或敲回车键);

曾道人在“Windows 功能”对话框中展开“Internet 信息服务”,“万维网服务”,“应用程序开发功能”,并选中“CGI”的选择框;

曾道人点击确定按钮并等待安装完成。

曾道人要在 Windows Server 2008 和 Windows Server 2008 R2 中激活 FastCGI 支持:

在 Windows 开始菜单中选择 "运行:",输入 "CompMgmtLauncher" 并点击 "确定";

曾道人或 打开服务器管理器-添加角色-Web 服务器(IIS),再勾选CGI后安装

激活FastCGI 模块后切换到phpstudy的IIS7+php5.2-5.5即可

不能启动的问题

有个别同学说不能在win7下使用,此程序已经在Win2000/xp/2003/win7/win8/win2008下测试成功,操作系统均专业版。apache启动不了,原因一是防火墙拦截,二是80端口已经被别的程序占用,如IIS,迅雷等;三是没有安装VC9运行库,php和apache都是VC9编译。解决以上三个问题,99%能一次性安装成功,如何不能成功,那1%的可能就是人品问题,就不要联系我了。

曾道人不是管理员administrator的用户,请右键以管理员身份运行。win8最好以管理员身份运行。牵扯到服务进程的管理必须以管理员身份运行。

曾道人端口问题无法启动时,请使用菜单『环境端口检测』进行端口检测,尝试启动。最重要的一点,你的机子一定要安装VC9运行库,phpStudy安装路径不得有汉字。

* 注:为防止软件被篡改,使用时请注意鉴别,提供以下md5码进行对比

1. phpStudy20161103.zip压缩包md5码:5bf5f785f027bf0c99cd02692cf7c322

曾道人2. phpStudy20161103.exe   md5码:1a16183868b865d67ebed2fc12e88467

全面适合 Win2000/XP/2003/win7/win8/win2008 操作系统 ,支持Apache、IIS、Nginx和LightTPD。

Apache+Nginx+LightTPD+IIS

曾道人php5.2 php5.3  php5.5 php7.0

曾道人MySQL phpMyAdmin MySQL-Front

曾道人16种组合自由切换,是下面5个版本的合集

新特征:完美支持win10,支持自定义php版本

更多>>软件截图

推荐软件

其他版本下载

精品推荐

相关文章

下载地址Android版iPhone版Mac版iPad版

  • phpstudy 2016(PHP环境一键安装包) 支持php7

查看所有评论>>网友评论

发表评论

(您的评论需要经过审核才能显示) 网友粉丝QQ群号:203046401

查看所有0条评论>>

更多>>猜你喜欢